Issues with VTiger 3
  • I have discovered a number of issues now that I am using VTiger on a daily basis and am hoping that someone could shed some light on them.

    1 - New Meeting then Select Contact

    When the box comes up to select a contact name from the Account the correct contact name will be there but there is nothing in the account field if you select contact name it appears to work but doesn’t actually add a contact name to the meeting.

    2 - Schedule New Phone Call for a Lead

    You can go into a lead and schedule a call then when you return to home page it tells you the call is scheduled but doesn't tell you who you're calling!

    Any ifo would be great!
  • 3 Comments sorted by
  • thanks for replying to the 2nd issue...

    the first issue happens when i try to schedule a new meeting.

    -click on new meeting
    -fill in meeting details and click on change beside the account field and you get a window with a list list of the available accounts.
    -pick correct account from list and you are taken back to the meeting window
    -press select contact button and you get a window with the contacts associated with that account (but i noticed that the box has the correct contact names but no corresponding account name)
    -select the contact to have the meeting and a blank line is inserted where you would expect the name of the contact to be. this blank line cannot be
    deleted and trying to edit just brings up blank contact details.

    i have discovered a work around for this that may indicate where the problem lies. if, when you press the select contact button, you remove the automatically inserted account name and then press search this brings up your entire contacts list, if you now select the contact then the correct details are inserted for the meeting.

    i have also noticed that in the invitees list for the meeting the user name is shown correctly in the 2nd field but not in the first field (which remains blank) even though the name is correct on the my account screen.

    i hope this explanation is clearer and once again thanks for your help!
  • hi,

    i am getting the following error when trying to add a business card.

    error setting account to call relationship:
    update calls set parent_id='89ea3a1c-4b81-9c3a-40dc-419c5304e8ae', parent_type='accounts' where _id='8baea2ba-81e5-af94-159d-419c53da7ae2' query failed:update calls set parent_id='89ea3a1c-4b81-9c3a-40dc-419c5304e8ae', parent_type='accounts' where _id='8baea2ba-81e5-af94-159d-419c53da7ae2'::mysql error 1054: unknown column '_id' in 'where clause'

    this may be a problem with my setup... is anyone else having this problem?

    thanks,
    joshua
  • "joshua" said:
    error setting account to call relationship:
    update calls set parent_id='89ea3a1c-4b81-9c3a-40dc-419c5304e8ae', parent_type='accounts' where _id='8baea2ba-81e5-af94-159d-419c53da7ae2' query failed:update calls set parent_id='89ea3a1c-4b81-9c3a-40dc-419c5304e8ae', parent_type='accounts' where _id='8baea2ba-81e5-af94-159d-419c53da7ae2'::mysql error 1054: unknown column '_id' in 'where clause'


    i fixed the problem:

    in:
    <vtiger>\modules\calls\call.php line: 228

    change:
    $query = "update $this->table_name set parent_id='$account_id', parent_type='accounts' where _id='$call_id'";

    to:
    $query = "update $this->table_name set parent_id='$account_id', parent_type='accounts' where id='$call_id'";


    this fixed the error. please let me know if i've made a mistake or accidently caused problems for some other module.

    cheers,
    joshua