Install on Fedora
  • Hello,
    I am having dificulty installing on Fedora.
    Installing in /opt/vtiger
    Following error is received as install is trying to make GD:


    -Wl,/opt/vtiger/vtigerCRM3_0/gd/lib
    testtr.o(.text+0xfd): In function `main':
    /home/downloads/vtiger/vtigerCRM_linux/gd-2.0.28/testtr.c:41: undefined reference to `gdImagePng'
    collect2: ld returned 1 exit status
    make[1]: *** [testtr] Error 1
    make[1]: Leaving directory `/home/bnelson/downloads/vtiger/vtigerCRM_linux/gd-2.0.28'
    make: *** [install-recursive] Error 1

    ************************ Error **********************
    Error while installing GD 2.0.28. Quitting setup ...



    I'm at a loss here. Any ideas?

    Thanks
  • 8 Comments sorted by
  • i had the exact same problem and this is what i figured out... the configure app doesn't fail if it doesn't find libpng which in this case is a requirement... so it goes to compile only to fail due to missing libpng...
  • also same for zlib which is also required...

    i was using slackware 10.0 and atm my install is still progressing proeprly but gd was properly installed already... i found out about these two errors when i tried manualy compiling gd and found the massive warnings in ./configure

    hope it helps... i guess on rpm based distros the pkg you will need is prolly libpng and libpng-devel and zlib and zlib-devel... just guessing... i never have problems with -devel stuff since slack installs all and so does sourcemage which is my default distro...
  • now it failed @ php and am trying to figure out if it's a freetype error:

    ************************ error **********************
    error while installing php 4.3.8. quitting setup ...
    *****************************************************

    warning: bad ps syntax, perhaps a bogus '-'? see http://procps.sf.net/faq.html

    from log:

    /root/vtigercrm_linux/php-4.3.8/ext/mysql/libmysql/my_tempnam.c:115: warning: the use of `tempnam' is dangerous, better use `mkstemp'
    ext/gd/gd.lo(.text+0x692): in function `zm_deactivate_gd':
    /root/vtigercrm_linux/php-4.3.8/ext/gd/gd.c:385: undefined reference to `gdfreefontcache'
    collect2: ld returned 1 exit status
    make: *** [sapi/cli/php] error 1

    since it's a freefontcache i'm am atm guessing freetype might be the problem
  • hi,

    please refer to the "vtiger crm - linux dependencies" document. this document may help you to figure out various packages to be installed before vtiger crm installation.

    http://prdownloads.sourceforge.net/vtig ... f?download

    ps: soon we will update this document with fedora related packages.

    thanks,
    gopal
    vtiger.com
  • i first got that same error at php. i had checked the dependancies & the xfree86 packages were the only ones i was missing. attempted the install again & the failures started happening at gd.

    all the packages listed as dependancies are installed, but maybe not in the location the install script is expecting them to be?
  • dear sir,

    though all the dependecy packages are installed, it is required that all these packages are present in the path of the konsole from which vtigercrm installer.bin is executed.

    thanks & regards
    don
  • hi,

    the error is due to non-availability of the libpng and libpng-dev packages.
    install these packages and try again.

    the followings are the dependency packages for fedora:

    [list]libpng
    libpng-devel
    libjpeg
    libjpeg-devel
    freetype
    freetype-devel
    zlib
    zlib-devel
    xorg-x11
    xorg-x11-dev[/list:u]
    please get back to us if you face any issues.

    thanks,
    gopal
    vtiger.com
  • hello,

    i have seen a few possible download of vtiger in .bin but it would be more convenient for my client to have a .repo setup so that he can resolve all depedencies through yum. he ask for it also since it is the official way to update fedora and he is a bit of a procedural junky.

    anyone has put vtiger in a public repository yet?

    thanks